{"action":"Upgrade modulemd to 1.3.2 or later.","affected":[{"fixed":"1.3.2","introduced":"0"}],"component":"modulemd","cve_ids":["CVE-2017-1002157"],"ecosystem":"PyPI","epss":0.02882,"exploited":false,"fixed_versions":["1.3.2"],"ghsa_id":"GHSA-jhjh-ghwx-6h7r","id":"tcs_01M5KFNZSR2WQFFHCC584VVNZF","modified_at":"2024-09-24T21:02:37.847874Z","published_at":"2019-01-17T13:56:18Z","references":["https://osv.dev/vulnerability/GHSA-jhjh-ghwx-6h7r","https://nvd.nist.gov/vuln/detail/CVE-2017-1002157","https://github.com/pypa/advisory-database/tree/main/vulns/modulemd/PYSEC-2019-153.yaml","https://github.com/xsuchy/modulemd","https://pagure.io/modulemd/issue/55"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-jhjh-ghwx-6h7r","url":"https://osv.dev/vulnerability/GHSA-jhjh-ghwx-6h7r"}],"summary":"modulemd uses an unsafe function for processing externally provided data"}