{"action":"Upgrade tensorflow-cpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29552"],"ecosystem":"PyPI","epss":0.00189,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-jhq9-wm9m-cf89","id":"tcs_01M5KFP10W3QYDRAZMW36KWD94","modified_at":"2026-07-08T06:29:08.111191009Z","published_at":"2021-05-21T14:23:48Z","references":["https://osv.dev/vulnerability/GHSA-jhq9-wm9m-cf89","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-jhq9-wm9m-cf89","https://nvd.nist.gov/vuln/detail/CVE-2021-29552","https://github.com/tensorflow/tensorflow/commit/704866eabe03a9aeda044ec91a8d0c83fc1ebdbe","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-480.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-678.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-189.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-jhq9-wm9m-cf89#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-jhq9-wm9m-cf89"}],"summary":"CHECK-failure in `UnsortedSegmentJoin`"}