{"action":"Upgrade wagtail to 5.2.6 or later.","affected":[{"fixed":"6.0.6","introduced":"6.0"},{"fixed":"6.1.3","introduced":"6.1"},{"fixed":"5.2.6","introduced":"2.0"}],"component":"wagtail","cve_ids":["CVE-2024-39317"],"ecosystem":"PyPI","epss":0.00615,"exploited":false,"fixed_versions":["6.0.6","6.1.3","5.2.6"],"ghsa_id":"GHSA-jmp3-39vp-fwg8","id":"tcs_01M5KFP9NX6T11VQVMF41NSFP2","modified_at":"2026-06-09T13:15:18.086289805Z","published_at":"2024-07-11T13:21:42Z","references":["https://osv.dev/vulnerability/GHSA-jmp3-39vp-fwg8","https://github.com/wagtail/wagtail/security/advisories/GHSA-jmp3-39vp-fwg8","https://nvd.nist.gov/vuln/detail/CVE-2024-39317","https://github.com/wagtail/wagtail/commit/31b1e8532dfb1b70d8d37d22aff9cbde9109cdf2","https://github.com/wagtail/wagtail/commit/3c941136f79c48446e3858df46e5b668d7f83797","https://github.com/wagtail/wagtail/commit/b783c096b6d4fd2cfc05f9137a0be288850e99a2","https://github.com/pypa/advisory-database/tree/main/vulns/wagtail/PYSEC-2024-86.yaml","https://github.com/wagtail/wagtail"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-jmp3-39vp-fwg8","url":"https://osv.dev/vulnerability/GHSA-jmp3-39vp-fwg8"}],"summary":"Wagtail regular expression denial-of-service via search query parsing"}