{"action":"Upgrade langroid to 0.53.15 or later.","affected":[{"fixed":"0.53.15","introduced":"0"}],"component":"langroid","cve_ids":["CVE-2025-46724"],"ecosystem":"PyPI","epss":0.0083,"exploited":false,"fixed_versions":["0.53.15"],"ghsa_id":"GHSA-jqq5-wc57-f8hj","id":"tcs_01M5KFPFAZZJFGAXHGDK27YG59","modified_at":"2026-07-01T23:00:12.917819525Z","published_at":"2025-05-20T18:00:27Z","references":["https://osv.dev/vulnerability/GHSA-jqq5-wc57-f8hj","https://github.com/langroid/langroid/security/advisories/GHSA-jqq5-wc57-f8hj","https://nvd.nist.gov/vuln/detail/CVE-2025-46724","https://github.com/langroid/langroid/commit/0d9e4a7bb3ae2eef8d38f2e970ff916599a2b2a6","https://github.com/langroid/langroid","https://github.com/pypa/advisory-database/tree/main/vulns/langroid/PYSEC-2026-381.yaml","https://pypi.org/project/langroid"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-jqq5-wc57-f8hj","url":"https://osv.dev/vulnerability/GHSA-jqq5-wc57-f8hj"}],"summary":"Langroid has a Code Injection vulnerability in TableChatAgent"}