{"action":"Upgrade scrapy to 1.8.1 or later.","affected":[{"fixed":"1.8.1","introduced":"0"},{"fixed":"2.5.1","introduced":"2.0.0"}],"component":"scrapy","cve_ids":["CVE-2021-41125"],"ecosystem":"PyPI","epss":0.01261,"exploited":false,"fixed_versions":["1.8.1","2.5.1"],"ghsa_id":"GHSA-jwqp-28gf-p498","id":"tcs_01M5KFPQRSFTTWF2FHEB2C00A8","modified_at":"2026-07-08T06:29:55.026270559Z","published_at":"2021-10-06T17:46:22Z","references":["https://osv.dev/vulnerability/GHSA-jwqp-28gf-p498","https://github.com/scrapy/scrapy/security/advisories/GHSA-jwqp-28gf-p498","https://nvd.nist.gov/vuln/detail/CVE-2021-41125","https://github.com/scrapy/scrapy/commit/b01d69a1bf48060daec8f751368622352d8b85a6","https://github.com/pypa/advisory-database/tree/main/vulns/scrapy/PYSEC-2021-363.yaml","https://github.com/scrapy/scrapy","https://lists.debian.org/debian-lts-announce/2022/03/msg00021.html","https://w3lib.readthedocs.io/en/latest/w3lib.html#w3lib.http.basic_auth_header","http://doc.scrapy.org/en/latest/topics/downloader-middleware.html#module-scrapy.downloadermiddlewares.httpauth"],"severity":{"label":"medium","score":5.7},"sources":[{"source":"osv","source_id":"GHSA-jwqp-28gf-p498","url":"https://osv.dev/vulnerability/GHSA-jwqp-28gf-p498"}],"summary":"Scrapy HTTP authentication credentials potentially leaked to target websites"}