{"action":"Upgrade sglang to 0.5.10 or later.","affected":[{"fixed":"0.5.10","introduced":"0"}],"component":"sglang","cve_ids":["CVE-2026-3060"],"ecosystem":"PyPI","epss":0.01202,"exploited":false,"fixed_versions":["0.5.10"],"ghsa_id":"GHSA-jx93-g359-86wm","id":"tcs_01M5KFPTGWG7JHQ4RH3AWA33KD","modified_at":"2026-06-29T12:26:46.288364029Z","published_at":"2026-03-12T12:30:29Z","references":["https://osv.dev/vulnerability/GHSA-jx93-g359-86wm","https://nvd.nist.gov/vuln/detail/CVE-2026-3060","https://github.com/sgl-project/sglang/pull/20904","https://github.com/sgl-project/sglang","https://github.com/sgl-project/sglang/blob/main/python/sglang/srt/disaggregation/encode_receiver.py","https://github.com/sgl-project/sglang/releases/tag/v0.5.10","https://orca.security/resources/blog/sglang-llm-framework-rce-vulnerabilities"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-jx93-g359-86wm","url":"https://osv.dev/vulnerability/GHSA-jx93-g359-86wm"}],"summary":"SGLang's encoder parallel disaggregation system is vulnerable to unauthenticated remote code execution through the disaggregation module"}