{"action":"Upgrade openclaw to 2026.3.31 or later.","affected":[{"fixed":"2026.3.31","introduced":"0"}],"component":"openclaw","cve_ids":["CVE-2026-41404"],"ecosystem":"npm","epss":0.0034,"exploited":false,"fixed_versions":["2026.3.31"],"ghsa_id":"GHSA-g374-mggx-p6xc","id":"tcs_01M5KFPV4ZZ27WVRXN0R2TYQQM","modified_at":"2026-05-05T16:11:35.803649Z","published_at":"2026-04-03T03:05:48Z","references":["https://osv.dev/vulnerability/GHSA-g374-mggx-p6xc","https://github.com/openclaw/openclaw/security/advisories/GHSA-g374-mggx-p6xc","https://github.com/openclaw/openclaw/commit/8b88b927cb0747ad24d95b07d35682bf85dc5b0e","https://github.com/openclaw/openclaw","https://github.com/openclaw/openclaw/releases/tag/v2026.3.31"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-g374-mggx-p6xc","url":"https://osv.dev/vulnerability/GHSA-g374-mggx-p6xc"}],"summary":"OpenClaw: Incomplete scope-clearing fix allows operator.admin escalation via trusted-proxy auth mode"}