{"action":"Upgrade tensorflow-gpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-29535"],"ecosystem":"PyPI","epss":0.00211,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-m3f9-w3p3-p669","id":"tcs_01M5KFQ2PHD4FW378K92E95ZE2","modified_at":"2026-09-10T03:49:05.583498927Z","published_at":"2021-05-21T14:22:28Z","references":["https://osv.dev/vulnerability/GHSA-m3f9-w3p3-p669","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-m3f9-w3p3-p669","https://nvd.nist.gov/vuln/detail/CVE-2021-29535","https://github.com/tensorflow/tensorflow/commit/efea03b38fb8d3b81762237dc85e579cc5fc6e87","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-463.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-661.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-172.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-m3f9-w3p3-p669#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-m3f9-w3p3-p669"}],"summary":"Heap buffer overflow in `QuantizedMul`"}