{"action":"Upgrade kafka-python to 2.3.2 or later.","affected":[{"fixed":"2.3.2","introduced":"0"}],"component":"kafka-python","cve_ids":["CVE-2026-10142"],"ecosystem":"PyPI","epss":0.00348,"exploited":false,"fixed_versions":["2.3.2"],"ghsa_id":"GHSA-m3px-q5gj-j9x7","id":"tcs_01M5KFQ3G37H1XEWCJ6ZNE9BKK","modified_at":"2026-09-10T03:51:08.925920927Z","published_at":"2026-06-11T00:32:04Z","references":["https://osv.dev/vulnerability/GHSA-m3px-q5gj-j9x7","https://nvd.nist.gov/vuln/detail/CVE-2026-10142","https://github.com/dpkp/kafka-python/pull/3019","https://github.com/dpkp/kafka-python/pull/3026","https://github.com/dpkp/kafka-python/commit/6e4831444f972d169cdd11f5c8d50333cea3f19b","https://github.com/dpkp/kafka-python/commit/9f92d0f53ecfee738c54638867c3d67f83017bca","https://github.com/dpkp/kafka-python","https://github.com/dpkp/kafka-python/releases/tag/2.3.2","https://github.com/pypa/advisory-database/tree/main/vulns/kafka-python/PYSEC-2026-2190.yaml","https://www.vulncheck.com/advisories/kafka-python-prior-to-denial-of-service-via-protocol-parser-frame-length"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-m3px-q5gj-j9x7","url":"https://osv.dev/vulnerability/GHSA-m3px-q5gj-j9x7"}],"summary":"kafka-python vulnerable to denial of service through an unvalidated protocol frame length"}