{"action":"Upgrade langchain-text-splitters to 0.3.9 or later.","affected":[{"fixed":"0.3.9","introduced":"0"}],"component":"langchain-text-splitters","cve_ids":["CVE-2025-6985"],"ecosystem":"PyPI","epss":0.00508,"exploited":false,"fixed_versions":["0.3.9"],"ghsa_id":"GHSA-m42m-m8cr-8m58","id":"tcs_01M5KFQ4FEEA4RW1P0DTQ713ZR","modified_at":"2026-09-10T03:50:30.091012895Z","published_at":"2025-10-06T18:31:07Z","references":["https://osv.dev/vulnerability/GHSA-m42m-m8cr-8m58","https://nvd.nist.gov/vuln/detail/CVE-2025-6985","https://github.com/langchain-ai/langchain/pull/31819","https://github.com/langchain-ai/langchain/commit/43eef435505a1c907227b724c0c760ad5fc01790","https://github.com/langchain-ai/langchain","https://huntr.com/bounties/cf78abbb-df3b-43de-b6ee-132b73ff8331"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-m42m-m8cr-8m58","url":"https://osv.dev/vulnerability/GHSA-m42m-m8cr-8m58"}],"summary":"LangChain Text Splitters is vulnerable to XML External Entity (XXE) attacks due to unsafe XSLT parsing"}