{"action":"Upgrade github.com/mudler/LocalAI to 2.22.0 or later.","affected":[{"fixed":"2.22.0","introduced":"0"}],"component":"github.com/mudler/LocalAI","cve_ids":["CVE-2024-9900"],"ecosystem":"Go","epss":0.00536,"exploited":false,"fixed_versions":["2.22.0"],"ghsa_id":"GHSA-w6hh-w36c-vxmw","id":"tcs_01M5KFQ9NA4YKSDDFZP8H616ZA","modified_at":"2025-03-25T20:22:02.028631Z","published_at":"2025-03-20T12:32:51Z","references":["https://osv.dev/vulnerability/GHSA-w6hh-w36c-vxmw","https://nvd.nist.gov/vuln/detail/CVE-2024-9900","https://github.com/mudler/localai/commit/a1634b219a4e52813e70ff07e6376a01449c4515","https://github.com/mudler/LocalAI","https://huntr.com/bounties/b39cd230-db66-471b-89b9-24afaa078e68"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-w6hh-w36c-vxmw","url":"https://osv.dev/vulnerability/GHSA-w6hh-w36c-vxmw"}],"summary":"LocalAI Cross-Site Scripting (XSS) vulnerability in its search functionality"}