{"action":"Upgrade nicegui to 3.5.0 or later.","affected":[{"fixed":"3.5.0","introduced":"2.22.0"}],"component":"nicegui","cve_ids":["CVE-2026-21872"],"ecosystem":"PyPI","epss":0.00271,"exploited":false,"fixed_versions":["3.5.0"],"ghsa_id":"GHSA-m7j5-rq9j-6jj9","id":"tcs_01M5KFQKA9RD81GGK83Z57G5QT","modified_at":"2026-07-07T17:56:55.537990652Z","published_at":"2026-01-08T20:08:42Z","references":["https://osv.dev/vulnerability/GHSA-m7j5-rq9j-6jj9","https://github.com/zauberzeug/nicegui/security/advisories/GHSA-m7j5-rq9j-6jj9","https://nvd.nist.gov/vuln/detail/CVE-2026-21872","https://github.com/zauberzeug/nicegui","https://github.com/zauberzeug/nicegui/releases/tag/v3.5.0"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-m7j5-rq9j-6jj9","url":"https://osv.dev/vulnerability/GHSA-m7j5-rq9j-6jj9"}],"summary":"NiceGUI apps are vulnerable to XSS which uses `ui.sub_pages` and render arbitrary user-provided links"}