{"action":"Upgrade github.com/coder/coder/v2 to 2.29.17 or later.","affected":[{"fixed":"2.34.2","introduced":"2.34.0"},{"fixed":"2.33.8","introduced":"2.33.0"},{"fixed":"2.32.7","introduced":"2.30.0"},{"fixed":"2.29.17","introduced":"0"}],"component":"github.com/coder/coder/v2","cve_ids":["CVE-2026-55428"],"ecosystem":"Go","epss":0.00405,"exploited":false,"fixed_versions":["2.34.2","2.33.8","2.32.7","2.29.17"],"ghsa_id":"GHSA-wrq8-fcv5-8hvp","id":"tcs_01M5KFR4CEG7Z67GSKVRW7QNE2","modified_at":"2026-07-07T16:11:26.924146346Z","published_at":"2026-07-06T20:58:30Z","references":["https://osv.dev/vulnerability/GHSA-wrq8-fcv5-8hvp","https://github.com/coder/coder/security/advisories/GHSA-wrq8-fcv5-8hvp","https://github.com/coder/coder/pull/26144","https://github.com/coder/coder"],"severity":{"label":"high","score":8.2},"sources":[{"source":"osv","source_id":"GHSA-wrq8-fcv5-8hvp","url":"https://osv.dev/vulnerability/GHSA-wrq8-fcv5-8hvp"}],"summary":"Coder: Route hijacking through lack of validation of agent-supplied AllowedIPs in tailnet coordinator"}