{"action":"Upgrade matrix-synapse to 1.95.1 or later.","affected":[{"fixed":"1.95.1","introduced":"0"}],"component":"matrix-synapse","cve_ids":["CVE-2023-43796"],"ecosystem":"PyPI","epss":0.01196,"exploited":false,"fixed_versions":["1.95.1"],"ghsa_id":"GHSA-mp92-3jfm-3575","id":"tcs_01M5KFRCEZ664YN4YAQY6Q6KJG","modified_at":"2026-09-10T03:49:24.728166201Z","published_at":"2023-10-31T20:29:49Z","references":["https://osv.dev/vulnerability/GHSA-mp92-3jfm-3575","https://github.com/matrix-org/synapse/security/advisories/GHSA-mp92-3jfm-3575","https://nvd.nist.gov/vuln/detail/CVE-2023-43796","https://github.com/matrix-org/synapse/commit/daec55e1fe120c564240c5386e77941372bf458f","https://github.com/matrix-org/synapse","https://github.com/pypa/advisory-database/tree/main/vulns/matrix-synapse/PYSEC-2023-230.yaml","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/2IDEEZMFJBDLTFHQUTZRJJNCOZGQ2ZVS","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VH3RNC5ZPQZ4OKPSL4E6BBJSZOQLGDEY","https://security.gentoo.org/glsa/202401-12"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-mp92-3jfm-3575","url":"https://osv.dev/vulnerability/GHSA-mp92-3jfm-3575"}],"summary":"Synapse vulnerable to leak of remote user device information"}