{"action":"Upgrade scapy to 2.4.1 or later.","affected":[{"fixed":"2.4.1","introduced":"2.4-rc1"}],"component":"scapy","cve_ids":["CVE-2019-1010142"],"ecosystem":"PyPI","epss":0.02791,"exploited":false,"fixed_versions":["2.4.1"],"ghsa_id":"GHSA-mpf2-q34c-fc6j","id":"tcs_01M5KFRCTYHAHPGMGGNWM5KEFG","modified_at":"2024-10-22T17:15:41.958674Z","published_at":"2019-07-22T14:53:58Z","references":["https://osv.dev/vulnerability/GHSA-mpf2-q34c-fc6j","https://nvd.nist.gov/vuln/detail/CVE-2019-1010142","https://github.com/secdev/scapy/pull/1409","https://github.com/secdev/scapy/pull/1409/files#diff-441eff981e466959968111fc6314fe93L1058","https://github.com/pypa/advisory-database/tree/main/vulns/scapy/PYSEC-2019-120.yaml","https://github.com/secdev/scapy","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/42NRPMC3NS2QVFNIXYP6WV2T3LMLLY7E","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/T46XW4S5BCA3VV3JT3C5Q6LBEXSIACLN","https://www.imperva.com/blog/scapy-sploit-python-network-tool-is-vulnerable-to-denial-of-service-dos-attack-cve-pending"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-mpf2-q34c-fc6j","url":"https://osv.dev/vulnerability/GHSA-mpf2-q34c-fc6j"}],"summary":"Infinite Loop in scapy"}