{"action":"Upgrade github.com/kubeedge/kubeedge to 1.9.3 or later.","affected":[{"fixed":"1.10.1","introduced":"1.10.0"},{"fixed":"1.9.3","introduced":"0"}],"component":"github.com/kubeedge/kubeedge","cve_ids":["CVE-2022-31077"],"ecosystem":"Go","epss":0.00839,"exploited":false,"fixed_versions":["1.10.1","1.9.3"],"ghsa_id":"GHSA-x938-fvfw-7jh5","id":"tcs_01M5KFRX5VSAW5AVHAVHZJ3PDZ","modified_at":"2024-08-21T15:41:43.507242Z","published_at":"2022-06-25T07:11:05Z","references":["https://osv.dev/vulnerability/GHSA-x938-fvfw-7jh5","https://github.com/kubeedge/kubeedge/security/advisories/GHSA-x938-fvfw-7jh5","https://nvd.nist.gov/vuln/detail/CVE-2022-31077","https://github.com/kubeedge/kubeedge/pull/3899","https://github.com/kubeedge/kubeedge/pull/3899/commits/5d60ae9eabd6b6b7afe38758e19bbe8137664701","https://github.com/kubeedge/kubeedge"],"severity":{"label":"medium","score":4},"sources":[{"source":"osv","source_id":"GHSA-x938-fvfw-7jh5","url":"https://osv.dev/vulnerability/GHSA-x938-fvfw-7jh5"}],"summary":"CloudCore CSI Driver: Malicious response from KubeEdge can crash CSI Driver controller server"}