{"action":"Upgrade mcp-server-kubernetes to 2.5.0 or later.","affected":[{"fixed":"2.5.0","introduced":"0"}],"component":"mcp-server-kubernetes","cve_ids":["CVE-2025-53355"],"ecosystem":"npm","epss":0.02239,"exploited":false,"fixed_versions":["2.5.0"],"ghsa_id":"GHSA-gjv4-ghm7-q58q","id":"tcs_01M5KFRXQEKET36Q9AFXHVAMG1","modified_at":"2026-02-04T02:27:48.731936Z","published_at":"2025-07-08T20:47:53Z","references":["https://osv.dev/vulnerability/GHSA-gjv4-ghm7-q58q","https://github.com/Flux159/mcp-server-kubernetes/security/advisories/GHSA-gjv4-ghm7-q58q","https://nvd.nist.gov/vuln/detail/CVE-2025-53355","https://github.com/Flux159/mcp-server-kubernetes/commit/ab165f5a0eea917fef5dbae954506fff6f4bf514","https://github.com/cyanheads/git-mcp-server/commit/0dbd6995ccdf76ab770b58013034365b2d06c4d9","https://equixly.com/blog/2025/03/29/mcp-server-new-security-nightmare","https://github.com/Flux159/mcp-server-kubernetes","https://invariantlabs.ai/blog/mcp-github-vulnerability"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-gjv4-ghm7-q58q","url":"https://osv.dev/vulnerability/GHSA-gjv4-ghm7-q58q"}],"summary":"MCP Server Kubernetes vulnerable to command injection in several tools"}