{"action":"Upgrade starlite to 1.51.2 or later.","affected":[{"fixed":"1.51.2","introduced":"0"}],"component":"starlite","cve_ids":["CVE-2023-25578"],"ecosystem":"PyPI","epss":0.01013,"exploited":false,"fixed_versions":["1.51.2"],"ghsa_id":"GHSA-p24m-863f-fm6q","id":"tcs_01M5KFS1B10DHNCX8ZZGC72B8D","modified_at":"2026-02-04T03:04:27.416791Z","published_at":"2023-02-15T17:42:42Z","references":["https://osv.dev/vulnerability/GHSA-p24m-863f-fm6q","https://github.com/starlite-api/starlite/security/advisories/GHSA-p24m-863f-fm6q","https://nvd.nist.gov/vuln/detail/CVE-2023-25578","https://github.com/starlite-api/starlite/commit/9674fe803628f986c03fe60769048cbc55b5bf83","https://github.com/pypa/advisory-database/tree/main/vulns/starlite/PYSEC-2023-49.yaml","https://github.com/starlite-api/starlite","https://github.com/starlite-api/starlite/releases/tag/v1.51.2"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-p24m-863f-fm6q","url":"https://osv.dev/vulnerability/GHSA-p24m-863f-fm6q"}],"summary":"Denial of service vulnerability when parsing multipart request body"}