{"action":"Upgrade github.com/jackc/pgx/v5 to 5.9.0 or later.","affected":[{"fixed":"5.9.0","introduced":"0"}],"component":"github.com/jackc/pgx/v5","cve_ids":["CVE-2026-33815"],"ecosystem":"Go","epss":0.00605,"exploited":false,"fixed_versions":["5.9.0"],"ghsa_id":"GHSA-xgrm-4fwx-7qm8","id":"tcs_01M5KFS6XZWHDT70EZ3V5JJH19","modified_at":"2026-09-10T03:50:44.892822027Z","published_at":"2026-04-07T18:31:36Z","references":["https://osv.dev/vulnerability/GHSA-xgrm-4fwx-7qm8","https://nvd.nist.gov/vuln/detail/CVE-2026-33815","https://github.com/jackc/pgx/issues/2519","https://github.com/jackc/pgx/issues/2530","https://github.com/jackc/pgx/commit/6dbad4cafdb8a4daab7ff79c858c95da4b6109e8","https://pkg.go.dev/vuln/GO-2026-4771"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-xgrm-4fwx-7qm8","url":"https://osv.dev/vulnerability/GHSA-xgrm-4fwx-7qm8"}],"summary":"pgx contains memory-safety vulnerability"}