{"action":"Upgrade sails to 1.5.7 or later.","affected":[{"fixed":"1.5.7","introduced":"0"}],"component":"sails","cve_ids":["CVE-2023-38504"],"ecosystem":"npm","epss":0.00937,"exploited":false,"fixed_versions":["1.5.7"],"ghsa_id":"GHSA-gpw9-fwm8-7rx7","id":"tcs_01M5KFS8Z2B63T4K00T8B51WJ0","modified_at":"2023-11-08T04:13:08.434892Z","published_at":"2023-07-27T17:13:14Z","references":["https://osv.dev/vulnerability/GHSA-gpw9-fwm8-7rx7","https://github.com/balderdashy/sails/security/advisories/GHSA-gpw9-fwm8-7rx7","https://nvd.nist.gov/vuln/detail/CVE-2023-38504","https://github.com/balderdashy/sails/pull/7287","https://github.com/balderdashy/sails/commit/4a023dc5095a4b30fdc8535f705ed34cd22d2f7d","https://github.com/balderdashy/sails","https://github.com/balderdashy/sails/releases/tag/v1.5.7"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-gpw9-fwm8-7rx7","url":"https://osv.dev/vulnerability/GHSA-gpw9-fwm8-7rx7"}],"summary":"DoS vulnerability for apps with sockets enabled"}