{"action":"Upgrade ansible to 2.7.17 or later.","affected":[{"fixed":"2.7.17","introduced":"2.7.0a1"},{"fixed":"2.8.11","introduced":"2.8.0a1"},{"fixed":"2.9.7","introduced":"2.9.0a1"}],"component":"ansible","cve_ids":["CVE-2020-10684"],"ecosystem":"PyPI","epss":0.00334,"exploited":false,"fixed_versions":["2.7.17","2.8.11","2.9.7"],"ghsa_id":"GHSA-p62g-jhg6-v3rq","id":"tcs_01M5KFSEZ585GFAKFVX2F62SX2","modified_at":"2024-11-27T06:12:03.552043Z","published_at":"2021-04-07T20:37:06Z","references":["https://osv.dev/vulnerability/GHSA-p62g-jhg6-v3rq","https://nvd.nist.gov/vuln/detail/CVE-2020-10684","https://github.com/ansible/ansible/commit/0b4788a71fc7d24ffa957a94ee5e23d6a9733ab0","https://github.com/ansible/ansible/commit/1d0d2645eed36ac4e17052ab4eacf240132d96fb","https://github.com/ansible/ansible/commit/5eabf7bb93c9bfc375b806a2b1f623d650cddc2b","https://github.com/ansible/ansible/commit/a9d2ceafe429171c0e2ad007058b88bae57c74ce","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10684","https://github.com/advisories/GHSA-p62g-jhg6-v3rq","https://github.com/ansible/ansible","https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-207.yaml","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DKPA4KC3OJSUFASUYMG66HKJE7ADNGFW","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MRRYUU5ZBLPBXCYG6CFP35D64NP2UB2S","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WQVOQD4VAIXXTVQAJKTN7NUGTJFE2PCB","https://security.gentoo.org/glsa/202006-11","https://www.debian.org/security/2021/dsa-4950"],"severity":{"label":"high","score":7.1},"sources":[{"source":"osv","source_id":"GHSA-p62g-jhg6-v3rq","url":"https://osv.dev/vulnerability/GHSA-p62g-jhg6-v3rq"}],"summary":"Code Injection, Race Condition, and Execution with Unnecessary Privileges in Ansible"}