{"action":"Upgrade gogs.io/gogs to 0.12.9 or later.","affected":[{"fixed":"0.12.9","introduced":"0"}],"component":"gogs.io/gogs","cve_ids":["CVE-2022-31038"],"ecosystem":"Go","epss":0.00737,"exploited":false,"fixed_versions":["0.12.9"],"ghsa_id":"GHSA-xq4v-vrp9-vcf2","id":"tcs_01M5KFSKPP4S5NCAJZ1P5EW814","modified_at":"2024-08-21T15:26:42.088920Z","published_at":"2022-06-08T22:24:25Z","references":["https://osv.dev/vulnerability/GHSA-xq4v-vrp9-vcf2","https://github.com/gogs/gogs/security/advisories/GHSA-xq4v-vrp9-vcf2","https://nvd.nist.gov/vuln/detail/CVE-2022-31038","https://github.com/gogs/gogs/pull/7009","https://github.com/gogs/gogs/commit/155cae1de8916fc3fde78f350763034b7422caee","https://github.com/gogs/gogs","https://github.com/gogs/gogs/releases/tag/v0.12.9"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-xq4v-vrp9-vcf2","url":"https://osv.dev/vulnerability/GHSA-xq4v-vrp9-vcf2"}],"summary":"Cross-site Scripting vulnerability in repository issue list in Gogs"}