{"action":"Upgrade next to 15.5.16 or later.","affected":[{"fixed":"15.5.16","introduced":"13.0.0"},{"fixed":"16.2.5","introduced":"16.0.0"}],"component":"next","cve_ids":["CVE-2026-44580"],"ecosystem":"npm","epss":0.00205,"exploited":false,"fixed_versions":["15.5.16","16.2.5"],"ghsa_id":"GHSA-gx5p-jg67-6x7h","id":"tcs_01M5KFSQGNN05ZPHBXTDQN7XQY","modified_at":"2026-09-10T03:51:05.785143220Z","published_at":"2026-05-11T15:56:38Z","references":["https://osv.dev/vulnerability/GHSA-gx5p-jg67-6x7h","https://github.com/vercel/next.js/security/advisories/GHSA-gx5p-jg67-6x7h","https://nvd.nist.gov/vuln/detail/CVE-2026-44580","https://github.com/vercel/next.js","https://github.com/vercel/next.js/releases/tag/v15.5.16","https://github.com/vercel/next.js/releases/tag/v16.2.5"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-gx5p-jg67-6x7h","url":"https://osv.dev/vulnerability/GHSA-gx5p-jg67-6x7h"}],"summary":"Next.js has cross-site scripting in beforeInteractive scripts with untrusted input"}