{"action":"Upgrade pywps to 4.5.0 or later.","affected":[{"fixed":"4.5.0","introduced":"0"}],"component":"pywps","cve_ids":["CVE-2021-39371"],"ecosystem":"PyPI","epss":0.01524,"exploited":false,"fixed_versions":["4.5.0"],"ghsa_id":"GHSA-p9wf-3xpg-c9g5","id":"tcs_01M5KFSRJ4EHD7BDGXFPW1GW9X","modified_at":"2024-10-24T22:27:01.351492Z","published_at":"2021-09-02T17:11:13Z","references":["https://osv.dev/vulnerability/GHSA-p9wf-3xpg-c9g5","https://nvd.nist.gov/vuln/detail/CVE-2021-39371","https://github.com/geopython/OWSLib/issues/790","https://github.com/geopython/pywps/pull/616","https://github.com/geopython/pywps/commit/7d6b26a2e931df2feca0b7fb24f4d01610825aee","https://github.com/advisories/GHSA-p9wf-3xpg-c9g5","https://github.com/geopython/pywps","https://github.com/pypa/advisory-database/tree/main/vulns/pywps/PYSEC-2021-121.yaml","https://lists.debian.org/debian-lts-announce/2021/09/msg00001.html"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-p9wf-3xpg-c9g5","url":"https://osv.dev/vulnerability/GHSA-p9wf-3xpg-c9g5"}],"summary":"XML External Entity Injection in PyWPS"}