{"action":"Upgrade tensorflow-gpu to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"},{"fixed":"2.7.1","introduced":"2.7.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-21736"],"ecosystem":"PyPI","epss":0.00752,"exploited":false,"fixed_versions":["2.5.3","2.6.3","2.7.1"],"ghsa_id":"GHSA-pfjj-m3jj-9jc9","id":"tcs_01M5KFSX6Q1Z3257R2V2G83XM2","modified_at":"2026-09-10T03:49:17.501538124Z","published_at":"2022-02-09T23:43:27Z","references":["https://osv.dev/vulnerability/GHSA-pfjj-m3jj-9jc9","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-pfjj-m3jj-9jc9","https://nvd.nist.gov/vuln/detail/CVE-2022-21736","https://github.com/tensorflow/tensorflow/commit/965b97e4a9650495cda5a8c210ef6684b4b9eceb","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2022-60.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2022-115.yaml","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/data/sparse_tensor_slice_dataset_op.cc#L227-L292"],"severity":{"label":"high","score":7.6},"sources":[{"source":"osv","source_id":"GHSA-pfjj-m3jj-9jc9#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-pfjj-m3jj-9jc9"}],"summary":"Undefined behavior in `SparseTensorSliceDataset`"}