{"action":"Upgrade transformers to 4.52.1 or later.","affected":[{"fixed":"4.52.1","introduced":"0"}],"component":"transformers","cve_ids":["CVE-2025-3777"],"ecosystem":"PyPI","epss":0.00406,"exploited":false,"fixed_versions":["4.52.1"],"ghsa_id":"GHSA-phhr-52qp-3mj4","id":"tcs_01M5KFT5GEJ3NEYNJNWRFP9WXH","modified_at":"2026-09-10T03:50:26.198077196Z","published_at":"2025-07-07T12:30:22Z","references":["https://osv.dev/vulnerability/GHSA-phhr-52qp-3mj4","https://nvd.nist.gov/vuln/detail/CVE-2025-3777","https://github.com/huggingface/transformers/commit/4dda5f71b35fb70cf602187eef84bb17a50b9082","https://github.com/huggingface/transformers","https://github.com/huggingface/transformers/blame/a7d2bbaaa8aac64f7c1ee8c1421cfe84b38359a4/src/transformers/image_utils.py","https://huntr.com/bounties/ccba0730-9248-4853-b7ff-5c20e6364f09"],"severity":{"label":"low","score":3.5},"sources":[{"source":"osv","source_id":"GHSA-phhr-52qp-3mj4","url":"https://osv.dev/vulnerability/GHSA-phhr-52qp-3mj4"}],"summary":"Transformers's Improper Input Validation vulnerability can be exploited through username injection"}