{"action":"Upgrade mqtt to 2.15.0 or later.","affected":[{"fixed":"2.15.0","introduced":"2.0.0"}],"component":"mqtt","cve_ids":["CVE-2017-10910"],"ecosystem":"npm","epss":0.02257,"exploited":false,"fixed_versions":["2.15.0"],"ghsa_id":"GHSA-h9mj-fghc-664w","id":"tcs_01M5KFTMYB8RCV3SN60W46EQ6R","modified_at":"2023-11-08T03:58:48.928864Z","published_at":"2017-12-28T22:51:58Z","references":["https://osv.dev/vulnerability/GHSA-h9mj-fghc-664w","https://nvd.nist.gov/vuln/detail/CVE-2017-10910","https://github.com/mqttjs/MQTT.js/commit/403ba53b838f2d319a0c0505a045fe00239e9923","https://github.com/advisories/GHSA-h9mj-fghc-664w","https://github.com/mqttjs/MQTT.js","https://github.com/mqttjs/MQTT.js/releases/tag/v2.15.0","https://github.com/nodejs/security-wg/blob/master/vuln/npm/357.json","https://jvn.jp/en/jp/JVN45494523/index.html","https://www.npmjs.com/advisories/555"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-h9mj-fghc-664w","url":"https://osv.dev/vulnerability/GHSA-h9mj-fghc-664w"}],"summary":"Denial of Service in mqtt"}