{"action":"Upgrade langchain to 0.0.325 or later.","affected":[{"fixed":"0.0.325","introduced":"0"}],"component":"langchain","cve_ids":["CVE-2023-39659"],"ecosystem":"PyPI","epss":0.01534,"exploited":false,"fixed_versions":["0.0.325"],"ghsa_id":"GHSA-prgp-w7vf-ch62","id":"tcs_01M5KFTP23F0TKP0X8QNS4CVNR","modified_at":"2024-09-27T21:33:25.955251Z","published_at":"2023-08-15T18:31:32Z","references":["https://osv.dev/vulnerability/GHSA-prgp-w7vf-ch62","https://nvd.nist.gov/vuln/detail/CVE-2023-39659","https://github.com/langchain-ai/langchain/issues/7700","https://github.com/langchain-ai/langchain/pull/12427","https://github.com/langchain-ai/langchain/pull/5640","https://github.com/langchain-ai/langchain/commit/cadfce295f8a33828fc635c2e5ea28b883e5c992","https://github.com/langchain-ai/langchain","https://github.com/langchain-ai/langchain/releases/tag/v0.0.325","https://github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2023-147.yaml"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-prgp-w7vf-ch62","url":"https://osv.dev/vulnerability/GHSA-prgp-w7vf-ch62"}],"summary":"LangChain vulnerable to arbitrary code execution"}