{"action":"Upgrade orjson to 3.9.15 or later.","affected":[{"fixed":"3.9.15","introduced":"0"}],"component":"orjson","cve_ids":["CVE-2024-27454"],"ecosystem":"PyPI","epss":0.01197,"exploited":false,"fixed_versions":["3.9.15"],"ghsa_id":"GHSA-pwr2-4v36-6qpr","id":"tcs_01M5KFTWWNG7YB13R0T0DAGT73","modified_at":"2026-09-10T03:50:09.881449775Z","published_at":"2024-02-26T18:30:31Z","references":["https://osv.dev/vulnerability/GHSA-pwr2-4v36-6qpr","https://nvd.nist.gov/vuln/detail/CVE-2024-27454","https://github.com/ijl/orjson/issues/458","https://github.com/ijl/orjson/commit/b0e4d2c06ce06c6e63981bf0276e4b7c74e5845e","https://github.com/ijl/orjson","https://github.com/ijl/orjson/blob/master/CHANGELOG.md#3915","https://github.com/pypa/advisory-database/tree/main/vulns/orjson/PYSEC-2024-40.yaml","https://monicz.dev/CVE-2024-27454"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-pwr2-4v36-6qpr","url":"https://osv.dev/vulnerability/GHSA-pwr2-4v36-6qpr"}],"summary":"orjson does not limit recursion for deeply nested JSON documents"}