{"action":"Upgrade tweepy to 3.0 or later.","affected":[{"fixed":"3.0","introduced":"0"}],"component":"tweepy","cve_ids":["CVE-2012-5825"],"ecosystem":"PyPI","epss":0.00609,"exploited":false,"fixed_versions":["3.0"],"ghsa_id":"GHSA-pwx5-xg7g-wpc5","id":"tcs_01M5KFTXNB67Y42TCP9JE83K1E","modified_at":"2024-11-18T23:01:15.491149Z","published_at":"2022-05-17T01:38:35Z","references":["https://osv.dev/vulnerability/GHSA-pwx5-xg7g-wpc5","https://nvd.nist.gov/vuln/detail/CVE-2012-5825","https://github.com/tweepy/tweepy/issues/279","https://github.com/tweepy/tweepy/pull/400","https://exchange.xforce.ibmcloud.com/vulnerabilities/79831","https://github.com/pypa/advisory-database/tree/main/vulns/tweepy/PYSEC-2012-17.yaml","https://github.com/tweepy/tweepy","http://www.cs.utexas.edu/~shmat/shmat_ccs12.pdf"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-pwx5-xg7g-wpc5","url":"https://osv.dev/vulnerability/GHSA-pwx5-xg7g-wpc5"}],"summary":"Tweepy does not verify SSL Certificate"}