{"action":"Upgrade openpgp to 4.2.0 or later.","affected":[{"fixed":"4.2.0","introduced":"0"}],"component":"openpgp","cve_ids":["CVE-2019-9154"],"ecosystem":"npm","epss":0.01615,"exploited":false,"fixed_versions":["4.2.0"],"ghsa_id":"GHSA-hfmf-q43v-2ffj","id":"tcs_01M5KFTXZD5X47RQ0DX6NFFVNC","modified_at":"2023-11-08T04:01:46.673910Z","published_at":"2019-08-23T21:42:18Z","references":["https://osv.dev/vulnerability/GHSA-hfmf-q43v-2ffj","https://nvd.nist.gov/vuln/detail/CVE-2019-9154","https://github.com/openpgpjs/openpgpjs/pull/797","https://github.com/openpgpjs/openpgpjs/pull/797/commits/47138eed61473e13ee8f05931119d3e10542c5e1","https://github.com/openpgpjs/openpgpjs/releases/tag/v4.2.0","https://sec-consult.com/en/blog/advisories/multiple-vulnerabilities-in-openpgp-js","https://snyk.io/vuln/SNYK-JS-OPENPGP-460247","https://www.bsi.bund.de/SharedDocs/Downloads/EN/BSI/Publications/Studies/Mailvelope_Extensions/Mailvelope_Extensions_pdf.html#download=1","https://www.npmjs.com/advisories/1161","http://packetstormsecurity.com/files/154191/OpenPGP.js-4.2.0-Signature-Bypass-Invalid-Curve-Attack.html"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-hfmf-q43v-2ffj","url":"https://osv.dev/vulnerability/GHSA-hfmf-q43v-2ffj"}],"summary":"Improper Key Verification in openpgp"}