{"action":"Upgrade mellium.im/xmpp to 0.21.1 or later.","affected":[{"fixed":"0.21.1","introduced":"0.18.0"}],"component":"mellium.im/xmpp","cve_ids":["CVE-2022-24968"],"ecosystem":"Go","epss":0.00539,"exploited":false,"fixed_versions":["0.21.1"],"ghsa_id":"GHSA-h289-x5wc-xcv8","id":"tcs_01M5KFVAPG2TE5PKF8N2MY15DG","modified_at":"2024-05-20T16:03:47Z","published_at":"2022-07-29T20:00:14Z","references":["https://osv.dev/vulnerability/GO-2022-0370","https://mellium.im/cve/cve-2022-24968/","https://github.com/mellium/xmpp/pull/260","https://github.com/mellium/xmpp/commit/0d92aa486da69b71f2f4a30e62aa722c711b98ac","https://mellium.im/issue/259"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"GO-2022-0370","url":"https://osv.dev/vulnerability/GO-2022-0370"}],"summary":"Man-in-the-middle attack due to improper validation of certificate in mellium.im/xmpp"}