{"action":"Upgrade celery to 5.2.2 or later.","affected":[{"fixed":"5.2.2","introduced":"0"}],"component":"celery","cve_ids":["CVE-2021-23727"],"ecosystem":"PyPI","epss":0.03598,"exploited":false,"fixed_versions":["5.2.2"],"ghsa_id":"GHSA-q4xr-rc97-m4xx","id":"tcs_01M5KFVB8AX2N25YE2HG3R88C8","modified_at":"2024-09-06T16:46:57.644996Z","published_at":"2022-01-06T22:22:02Z","references":["https://osv.dev/vulnerability/GHSA-q4xr-rc97-m4xx","https://nvd.nist.gov/vuln/detail/CVE-2021-23727","https://github.com/celery/celery/commit/1f7ad7e6df1e02039b6ab9eec617d283598cad6b","https://github.com/advisories/GHSA-q4xr-rc97-m4xx","https://github.com/celery/celery","https://github.com/celery/celery/blob/master/Changelog.rst%23522","https://github.com/pypa/advisory-database/tree/main/vulns/celery/PYSEC-2021-858.yaml","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/SYXRGHWHD2WWMHBWCVD5ULVINPKNY3P5","https://snyk.io/vuln/SNYK-PYTHON-CELERY-2314953"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-q4xr-rc97-m4xx","url":"https://osv.dev/vulnerability/GHSA-q4xr-rc97-m4xx"}],"summary":"OS Command Injection in celery"}