{"action":"Upgrade github.com/argoproj/argo-workflows/v3 to 3.0.9 or later.","affected":[{"fixed":"3.0.9","introduced":"3.0.0"},{"fixed":"3.1.6","introduced":"3.1.0"}],"component":"github.com/argoproj/argo-workflows/v3","cve_ids":[],"ecosystem":"Go","exploited":false,"fixed_versions":["3.0.9","3.1.6"],"ghsa_id":"GHSA-prqf-xr2j-xf65","id":"tcs_01M5KFVEX3NEK9M4NE9PKH1FDV","modified_at":"2026-03-03T04:50:11.395007Z","published_at":"2024-08-21T14:30:31Z","references":["https://osv.dev/vulnerability/GO-2022-0405","https://github.com/argoproj/argo-workflows/security/advisories/GHSA-prqf-xr2j-xf65"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"GO-2022-0405#Go/github.com/argoproj/argo-workflows/v3","url":"https://osv.dev/vulnerability/GO-2022-0405"}],"summary":"Potential privilege escalation on Kubernetes >= v1.19 when the Argo Sever is run with `--auth-mode=client` in github.com/argoproj/argo-workflows"}