{"action":"Upgrade dagster to 1.5.11 or later.","affected":[{"fixed":"1.5.11","introduced":"0"}],"component":"dagster","cve_ids":["CVE-2023-51232"],"ecosystem":"PyPI","epss":0.00946,"exploited":false,"fixed_versions":["1.5.11"],"ghsa_id":"GHSA-q93c-p2mw-p23f","id":"tcs_01M5KFVQ2SBDFSHNZQH2YB20C4","modified_at":"2026-07-07T17:57:06.251157938Z","published_at":"2025-07-07T15:30:38Z","references":["https://osv.dev/vulnerability/GHSA-q93c-p2mw-p23f","https://nvd.nist.gov/vuln/detail/CVE-2023-51232","https://github.com/dagster-io/dagster/pull/18462","https://github.com/dagster-io/dagster/commit/dbb064c2ddda74265b8174edd9775e1302ca6ba0","https://github.com/dagster-io/dagster"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-q93c-p2mw-p23f","url":"https://osv.dev/vulnerability/GHSA-q93c-p2mw-p23f"}],"summary":"Dagster vulnerable to Path Traversal attack through its /logs endpoint"}