{"action":"Upgrade flowise to 3.0.6 or later.","affected":[{"fixed":"3.0.6","introduced":"3.0.5"}],"component":"flowise","cve_ids":["CVE-2025-59527"],"ecosystem":"npm","epss":0.05202,"exploited":false,"fixed_versions":["3.0.6"],"ghsa_id":"GHSA-hr92-4q35-4j3m","id":"tcs_01M5KFVZ5AHZ7F6QHC3GNKB54N","modified_at":"2025-09-22T21:58:31Z","published_at":"2025-09-15T19:53:46Z","references":["https://osv.dev/vulnerability/GHSA-hr92-4q35-4j3m","https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-hr92-4q35-4j3m","https://nvd.nist.gov/vuln/detail/CVE-2025-59527","https://github.com/FlowiseAI/Flowise","https://github.com/FlowiseAI/Flowise/blob/5930f1119c655bcf8d2200ae827a1f5b9fec81d0/packages/components/src/utils.ts#L474-L478","https://github.com/FlowiseAI/Flowise/blob/5930f1119c655bcf8d2200ae827a1f5b9fec81d0/packages/server/src/controllers/fetch-links/index.ts#L6-L24","https://github.com/FlowiseAI/Flowise/blob/5930f1119c655bcf8d2200ae827a1f5b9fec81d0/packages/server/src/services/fetch-links/index.ts#L8-L18","https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.0.6"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-hr92-4q35-4j3m","url":"https://osv.dev/vulnerability/GHSA-hr92-4q35-4j3m"}],"summary":"FlowiseAI/Flowise has Server-Side Request Forgery (SSRF) vulnerability"}