{"action":"Upgrade ansible to 1.5.4 or later.","affected":[{"fixed":"1.5.4","introduced":"0"}],"component":"ansible","cve_ids":["CVE-2014-4657"],"ecosystem":"PyPI","epss":0.04427,"exploited":false,"fixed_versions":["1.5.4"],"ghsa_id":"GHSA-qg47-5px9-32g7","id":"tcs_01M5KFW137D0NF6NRJZRVRXT31","modified_at":"2025-02-19T05:27:52.651164Z","published_at":"2022-05-17T19:57:32Z","references":["https://osv.dev/vulnerability/GHSA-qg47-5px9-32g7","https://nvd.nist.gov/vuln/detail/CVE-2014-4657","https://github.com/ansible/ansible/commit/998793fd0ab55705d57527a38cee5e83f535974c","https://github.com/ansible/ansible","https://github.com/ansible/ansible/blob/release1.5.5/CHANGELOG.md","https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-199.yaml","https://web.archive.org/web/20210120133852/https://www.securityfocus.com/bid/68232"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-qg47-5px9-32g7","url":"https://osv.dev/vulnerability/GHSA-qg47-5px9-32g7"}],"summary":"Ansible Remote Code Execution"}