{"action":"Upgrade express-xss-sanitizer to 2.0.1 or later.","affected":[{"fixed":"2.0.1","introduced":"0"}],"component":"express-xss-sanitizer","cve_ids":["CVE-2025-59364"],"ecosystem":"npm","epss":0.00449,"exploited":false,"fixed_versions":["2.0.1"],"ghsa_id":"GHSA-hvq2-wf92-j4f3","id":"tcs_01M5KFW4P0GGPD1G6651KWTT49","modified_at":"2025-09-26T14:57:09.094984Z","published_at":"2025-09-26T14:38:13Z","references":["https://osv.dev/vulnerability/GHSA-hvq2-wf92-j4f3","https://github.com/AhmedAdelFahim/express-xss-sanitizer/security/advisories/GHSA-hvq2-wf92-j4f3","https://nvd.nist.gov/vuln/detail/CVE-2025-59364","https://github.com/AhmedAdelFahim/express-xss-sanitizer/pull/23","https://github.com/AhmedAdelFahim/express-xss-sanitizer/commit/62d6542a2a57298da7a2e02de623454007e4f6d6","https://dbugs.ptsecurity.com/vulnerability/PT-2025-37434","https://gist.github.com/Spendroslav/177804eaef5acfb222a550de212a1b94","https://github.com/AhmedAdelFahim/express-xss-sanitizer","https://www.npmjs.com/package/express-xss-sanitizer","https://www.tenable.com/cve/CVE-2025-59364"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-hvq2-wf92-j4f3","url":"https://osv.dev/vulnerability/GHSA-hvq2-wf92-j4f3"},{"source":"nvd","source_id":"CVE-2025-59364","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-59364"}],"summary":"express-xss-sanitizer has an unbounded recursion depth"}