{"action":"Upgrade tensorflow to 2.7.2 or later.","affected":[{"fixed":"2.7.2","introduced":"0"},{"fixed":"2.8.1","introduced":"2.8.0"},{"fixed":"2.9.1","introduced":"2.9.0"}],"component":"tensorflow","cve_ids":["CVE-2022-35998"],"ecosystem":"PyPI","epss":0.00488,"exploited":false,"fixed_versions":["2.7.2","2.8.1","2.9.1"],"ghsa_id":"GHSA-qhw4-wwr7-gjc5","id":"tcs_01M5KFW78J2D01N9MSQN00NP9Y","modified_at":"2026-07-07T11:56:03.474012360Z","published_at":"2022-09-16T22:09:57Z","references":["https://osv.dev/vulnerability/GHSA-qhw4-wwr7-gjc5","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-qhw4-wwr7-gjc5","https://nvd.nist.gov/vuln/detail/CVE-2022-35998","https://github.com/tensorflow/tensorflow/commit/c8ba76d48567aed347508e0552a257641931024d","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/releases/tag/v2.10.0"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"GHSA-qhw4-wwr7-gjc5","url":"https://osv.dev/vulnerability/GHSA-qhw4-wwr7-gjc5"}],"summary":"TensorFlow vulnerable to `CHECK` fail in `EmptyTensorList`"}