{"action":"Upgrade py-cord to 2.0.1 or later.","affected":[{"fixed":"2.0.1","introduced":"2.0.0"}],"component":"py-cord","cve_ids":["CVE-2022-36024"],"ecosystem":"PyPI","epss":0.00797,"exploited":false,"fixed_versions":["2.0.1"],"ghsa_id":"GHSA-qmhj-m29v-gvmr","id":"tcs_01M5KFWCDF7MGQ3YT4PNS744BT","modified_at":"2024-11-26T18:46:54Z","published_at":"2022-08-18T14:18:37Z","references":["https://osv.dev/vulnerability/GHSA-qmhj-m29v-gvmr","https://github.com/Pycord-Development/pycord/security/advisories/GHSA-qmhj-m29v-gvmr","https://nvd.nist.gov/vuln/detail/CVE-2022-36024","https://github.com/Pycord-Development/pycord/pull/1568","https://github.com/Pycord-Development/pycord","https://github.com/pypa/advisory-database/tree/main/vulns/py-cord/PYSEC-2022-43146.yaml"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-qmhj-m29v-gvmr","url":"https://osv.dev/vulnerability/GHSA-qmhj-m29v-gvmr"}],"summary":"Bots using py-cord as Discord API wrapper are vulnerable to shutdowns through remote code execution"}