{"action":"Upgrade loopback-connector-postgresql to 5.5.1 or later.","affected":[{"fixed":"5.5.1","introduced":"0"}],"component":"loopback-connector-postgresql","cve_ids":["CVE-2022-35942"],"ecosystem":"npm","epss":0.00638,"exploited":false,"fixed_versions":["5.5.1"],"ghsa_id":"GHSA-j259-6c58-9m58","id":"tcs_01M5KFWHP0187K7QT3THR7VJ1P","modified_at":"2023-11-08T04:09:53.649923Z","published_at":"2022-08-11T21:13:43Z","references":["https://osv.dev/vulnerability/GHSA-j259-6c58-9m58","https://github.com/loopbackio/loopback-connector-postgresql/security/advisories/GHSA-j259-6c58-9m58","https://nvd.nist.gov/vuln/detail/CVE-2022-35942","https://github.com/loopbackio/loopback-connector-postgresql/commit/d57406c6737692a3a106b58a35406290cddb23e5","https://github.com/loopbackio/loopback-connector-postgresql"],"severity":{"label":"critical","score":9.3},"sources":[{"source":"osv","source_id":"GHSA-j259-6c58-9m58","url":"https://osv.dev/vulnerability/GHSA-j259-6c58-9m58"}],"summary":"loopback-connector-postgresql Vulnerable to Improper Sanitization of `contains` Filter"}