{"action":"Upgrade libpq to 1.8.10 or later.","affected":[{"fixed":"1.8.10","introduced":"0"}],"component":"libpq","cve_ids":["CVE-2022-25852"],"ecosystem":"npm","epss":0.01378,"exploited":false,"fixed_versions":["1.8.10"],"ghsa_id":"GHSA-j32j-2hxv-rqf7","id":"tcs_01M5KFWKW02Z134B1WP90C9THC","modified_at":"2023-11-08T04:08:49.257876Z","published_at":"2022-06-18T00:00:20Z","references":["https://osv.dev/vulnerability/GHSA-j32j-2hxv-rqf7","https://nvd.nist.gov/vuln/detail/CVE-2022-25852","https://github.com/brianc/node-libpq/issues/84","https://github.com/brianc/node-libpq/pull/86","https://snyk.io/vuln/SNYK-JS-LIBPQ-2392366","https://snyk.io/vuln/SNYK-JS-PGNATIVE-2392365"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-j32j-2hxv-rqf7","url":"https://osv.dev/vulnerability/GHSA-j32j-2hxv-rqf7"}],"summary":"pg-native and libpq vulnerable to uncontrolled resource consumption"}