{"action":"Upgrade vm2 to 3.11.7 or later.","affected":[{"fixed":"3.11.7","introduced":"0"}],"component":"vm2","cve_ids":["CVE-2026-92946"],"ecosystem":"npm","epss":0.00776,"exploited":false,"fixed_versions":["3.11.7"],"ghsa_id":"GHSA-j3hm-6rg5-mchv","id":"tcs_01M5KFWPVMS05KET85AZK35ADY","modified_at":"2026-10-05T22:45:04.556252300Z","published_at":"2026-10-05T22:34:50Z","references":["https://osv.dev/vulnerability/GHSA-j3hm-6rg5-mchv","https://github.com/patriksimek/vm2/security/advisories/GHSA-j3hm-6rg5-mchv","https://nvd.nist.gov/vuln/detail/CVE-2026-92946","https://github.com/patriksimek/vm2/commit/903017c8a1eae9aba947ec854468b48155e79f86","https://github.com/patriksimek/vm2","https://github.com/patriksimek/vm2/releases/tag/v3.11.7","https://www.vulncheck.com/advisories/vm2-before-3.11.7-remote-code-execution-via-require-external"],"severity":{"label":"critical","score":10},"sources":[{"source":"osv","source_id":"GHSA-j3hm-6rg5-mchv","url":"https://osv.dev/vulnerability/GHSA-j3hm-6rg5-mchv"}],"summary":"vm2: NodeVM `require.external` without an explicit `require.root` grants unrestricted host filesystem access and full RCE"}