{"action":"Upgrade wheel to 0.38.1 or later.","affected":[{"fixed":"0.38.1","introduced":"0"}],"component":"wheel","cve_ids":["CVE-2022-40898"],"ecosystem":"PyPI","epss":0.02837,"exploited":false,"fixed_versions":["0.38.1"],"ghsa_id":"GHSA-qwmp-2cf2-g9g6","id":"tcs_01M5KFWSEYH1QTTS9GTM3XQ6J0","modified_at":"2024-11-19T19:22:35.244591Z","published_at":"2022-12-23T00:30:23Z","references":["https://osv.dev/vulnerability/GHSA-qwmp-2cf2-g9g6","https://nvd.nist.gov/vuln/detail/CVE-2022-40898","https://github.com/pypa/advisory-database/tree/main/vulns/wheel/PYSEC-2022-43017.yaml","https://github.com/pypa/wheel","https://github.com/pypa/wheel/blob/main/src/wheel/wheelfile.py#L18","https://pypi.org/project/wheel","https://pyup.io/posts/pyup-discovers-redos-vulnerabilities-in-top-python-packages","https://pyup.io/vulnerabilities/CVE-2022-40898/51499"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-qwmp-2cf2-g9g6","url":"https://osv.dev/vulnerability/GHSA-qwmp-2cf2-g9g6"}],"summary":"pypa/wheel vulnerable to Regular Expression denial of service (ReDoS)"}