{"action":"Upgrade apache-airflow-providers-apache-spark to 4.1.3 or later.","affected":[{"fixed":"4.1.3","introduced":"0"}],"component":"apache-airflow-providers-apache-spark","cve_ids":["CVE-2023-40272"],"ecosystem":"PyPI","epss":0.02144,"exploited":false,"fixed_versions":["4.1.3"],"ghsa_id":"GHSA-r2f6-6928-fh8f","id":"tcs_01M5KFWZG4724G8KSSFRVY4XQV","modified_at":"2026-07-07T17:57:18.867451071Z","published_at":"2023-08-17T15:30:23Z","references":["https://osv.dev/vulnerability/GHSA-r2f6-6928-fh8f","https://nvd.nist.gov/vuln/detail/CVE-2023-40272","https://lists.apache.org/thread/t03gktyzyor20rh06okd91jtqmw6k1l7","http://www.openwall.com/lists/oss-security/2023/08/17/1","http://www.openwall.com/lists/oss-security/2023/08/18/1"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-r2f6-6928-fh8f","url":"https://osv.dev/vulnerability/GHSA-r2f6-6928-fh8f"}],"summary":"Apache Airflow Spark Provider Improper Input Validation vulnerability"}