{"action":"Upgrade weave to 0.50.8 or later.","affected":[{"fixed":"0.50.8","introduced":"0"}],"component":"weave","cve_ids":["CVE-2024-7340"],"ecosystem":"PyPI","epss":0.05015,"exploited":false,"fixed_versions":["0.50.8"],"ghsa_id":"GHSA-r49h-6qxq-624f","id":"tcs_01M5KFX4QGTVK8M46S2XEAFKYC","modified_at":"2026-07-07T17:56:29.844269650Z","published_at":"2024-07-31T15:31:19Z","references":["https://osv.dev/vulnerability/GHSA-r49h-6qxq-624f","https://nvd.nist.gov/vuln/detail/CVE-2024-7340","https://github.com/wandb/weave/pull/1657","https://github.com/wandb/weave/commit/f43d5fb75e0d52933a52ecd9a0ce2f9b082e6c9f","https://github.com/wandb/weave","https://research.jfrog.com/vulnerabilities/wandb-weave-server-remote-arbitrary-file-leak-jfsa-2024-001039248"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-r49h-6qxq-624f","url":"https://osv.dev/vulnerability/GHSA-r49h-6qxq-624f"}],"summary":"Weave server API vulnerable to arbitrary file leak"}