{"action":"Upgrade tensorflow-gpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-29524"],"ecosystem":"PyPI","epss":0.00189,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-r4pj-74mg-8868","id":"tcs_01M5KFX63MA6MWNJKHN3CA4EVR","modified_at":"2026-09-10T03:49:14.944707522Z","published_at":"2021-05-21T14:21:47Z","references":["https://osv.dev/vulnerability/GHSA-r4pj-74mg-8868","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-r4pj-74mg-8868","https://nvd.nist.gov/vuln/detail/CVE-2021-29524","https://github.com/tensorflow/tensorflow/commit/fca9874a9b42a2134f907d2fb46ab774a831404a","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-452.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-650.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-161.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-r4pj-74mg-8868#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-r4pj-74mg-8868"}],"summary":"Division by 0 in `Conv2DBackpropFilter`"}