{"action":"Upgrade octavia to 2.1.2 or later.","affected":[{"fixed":"2.1.2","introduced":"0.10.0"},{"fixed":"3.2.0","introduced":"3.0.0"},{"fixed":"4.1.0","introduced":"4.0.0"}],"component":"octavia","cve_ids":["CVE-2019-17134"],"ecosystem":"PyPI","epss":0.02316,"exploited":false,"fixed_versions":["2.1.2","3.2.0","4.1.0"],"ghsa_id":"GHSA-r4v4-3jj7-jc29","id":"tcs_01M5KFX6DEFA39ADFHVS0FVEHG","modified_at":"2026-06-29T12:26:18.123247975Z","published_at":"2022-05-24T16:58:03Z","references":["https://osv.dev/vulnerability/GHSA-r4v4-3jj7-jc29","https://nvd.nist.gov/vuln/detail/CVE-2019-17134","https://github.com/openstack/octavia/commit/1725517d1d209f26b2275306d83e49c099dcbe1a","https://github.com/openstack/octavia/commit/2976a7f0f109e17930db8a61136526ead44ea7e5","https://github.com/openstack/octavia/commit/624ff08f27bcb73788663cbe6d35cbe29c537844","https://github.com/openstack/octavia/commit/89a2f6e0136ad49d928eb65b4cf555af2a2b8ab1","https://github.com/openstack/octavia/commit/b0c2cd7b4c835c391cfedf12cf9f9ff8a0aabd17","https://github.com/openstack/octavia/commit/c2fdffc3b748f8007c72e52df257e38756923b40","https://github.com/openstack/octavia","https://review.opendev.org/686541","https://review.opendev.org/686543","https://review.opendev.org/686544","https://review.opendev.org/686545","https://review.opendev.org/686546","https://review.opendev.org/686547","https://security.openstack.org/ossa/OSSA-2019-005.html","https://storyboard.openstack.org/#!/story/2006660"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"GHSA-r4v4-3jj7-jc29","url":"https://osv.dev/vulnerability/GHSA-r4v4-3jj7-jc29"}],"summary":"OpenStack Octavia Amphora-Agent not requiring Client-Certificate"}