{"action":"Upgrade ansible to 2.9.6 or later.","affected":[{"fixed":"2.9.6","introduced":"0"}],"component":"ansible","cve_ids":["CVE-2020-10729"],"ecosystem":"PyPI","epss":0.00435,"exploited":false,"fixed_versions":["2.9.6"],"ghsa_id":"GHSA-r6h7-5pq2-j77h","id":"tcs_01M5KFXB76RW8D9FWC8HZCN0MH","modified_at":"2024-09-10T19:48:38.347546Z","published_at":"2021-06-15T16:10:11Z","references":["https://osv.dev/vulnerability/GHSA-r6h7-5pq2-j77h","https://nvd.nist.gov/vuln/detail/CVE-2020-10729","https://github.com/ansible/ansible/issues/34144","https://github.com/ansible/ansible/pull/67429","https://github.com/ansible/ansible/commit/c520d70bf4748c8ee6718a7d0d0254051ba1c2e9","https://bugzilla.redhat.com/show_bug.cgi?id=1831089","https://github.com/advisories/GHSA-r6h7-5pq2-j77h","https://github.com/ansible/ansible","https://github.com/ansible/ansible/blob/v2.9.6/changelogs/CHANGELOG-v2.9.rst","https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2021-105.yaml","https://www.debian.org/security/2021/dsa-4950"],"severity":{"label":"medium","score":5},"sources":[{"source":"osv","source_id":"GHSA-r6h7-5pq2-j77h","url":"https://osv.dev/vulnerability/GHSA-r6h7-5pq2-j77h"}],"summary":"Insufficiently random values in Ansible"}