{"action":"Upgrade go.pinniped.dev to 0.19.0 or later.","affected":[{"fixed":"0.19.0","introduced":"0.3.0"}],"component":"go.pinniped.dev","cve_ids":["CVE-2022-31677"],"ecosystem":"Go","epss":0.00458,"exploited":false,"fixed_versions":["0.19.0"],"ghsa_id":"GHSA-rp4v-hhm6-rcv9","id":"tcs_01M5KFXGNQKFFK7P95BVG1P13T","modified_at":"2026-03-03T04:52:32.750925Z","published_at":"2024-08-21T16:03:21Z","references":["https://osv.dev/vulnerability/GO-2022-0981","https://github.com/vmware-tanzu/pinniped/security/advisories/GHSA-rp4v-hhm6-rcv9","https://nvd.nist.gov/vuln/detail/CVE-2022-31677","https://github.com/vmware-tanzu/pinniped/pull/1264","https://github.com/vmware-tanzu/pinniped/releases/tag/v0.19.0"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"GO-2022-0981","url":"https://osv.dev/vulnerability/GO-2022-0981"}],"summary":"Pinniped Supervisor Insufficient Session Expiration vulnerability in go.pinniped.dev"}